ログイン
検索
メインメニュー
開発者ブログ
ChangeVisionメンバーズ分布マップ
フォーラム一覧   -   トピック一覧
   astah*の使い方
     astah professionalでプラグインがインストールできません。
投稿するにはまず登録を

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 トピック
omae
投稿日時: 2015-10-3 18:42
新米
登録日: 2015-10-3
居住地:
投稿: 3
astah professionalでプラグインがインストールできません。
astah professionalにおきまして、C++リバースプラグインがインストールできません。
astah professionalのバージョンは6.5です。
使い方にあります、
メインメニュー[ヘルプ] - [プラグイン一覧]を開いても「インストール」ボタンがありません。
存在するのは、一覧表示(空表示)と「ダウンロードサイト」ボタンがあるのみです。

どのようにしてプラグインのインストールするのかやり方を教えてください。
よろしくお願いいたします。

joba
投稿日時: 2015-10-5 12:06
開発者
登録日: 2006-4-27
居住地: Fukui
投稿: 597
Re: astah professionalでプラグインがインストールできません。
こんにちは。この度は、プラグインインストールでご不便おかけして申し訳ありません。
では、次の手順をお試しください。

(1) astah*を一旦終了します
(2) 下のディレクトリに、[plugins]という名前のフォルダが存在しない場合は、作成してください
- ユーザーホーム/.astah/professional/plugins
- astah* professionalインストールフォルダ/plugins
(3) C++リバースプラグインファイル(cplusreverse-x.x.x.jar)を、上の両方の場所に保存します
(4) astah*を再起動します

メインメニュー[ツール] - [C++]配下に、C++リバース用のメニューが追加されていればインストールは成功です。

astah* 6.5のプラグイン機構は、「アルファー版」としてのご提供の為、何かとご不便おかけして誠に申し訳ありません。
omae
投稿日時: 2015-10-5 23:25
新米
登録日: 2015-10-3
居住地:
投稿: 3
Re: astah professionalでプラグインがインストールできません。
ご回答ありがとうございます。
ご指定の方法で行ったのですが、やはり、プラグインが使用できるようにはなりませんでした。
(メインメニュー[ツール] - [C++]配下に、C++リバース用のメニューが追加されません。)

下記に行った手順を記載いたします。申し訳ありませんが、ご教授お願いいたします。

(1) astah*を一旦終了。
(2) - ユーザーホーム/.astah/professional/plugins
→pluginsフォルダを新規作成
- astah* professionalインストールフォルダ/plugins
→pluginsフォルダ既に存在していたので、そのまま使用。
※同一階層にcashフォルダがありましたが、特に何もしていません。
cplusreverse-x.x.x.jar(バージョンは1.0.9)を、上の両方の場所に保存。
(3)astah*を再起動。
(4)メインメニュー[ヘルプ] - [プラグイン一覧]を確認。下記が表示。
名前:C++リバース
バージョン:1.0.9
説明:DoxygenでC++ソースコードを・・・(以下略)
識別名:com.charge_vision・・・(以下略)
状態:RESOLVED

(5)メインメニュー[ツール] - [C++]配下に、C++リバース用のメニューが追加されていない。

よろしくお願いいたします。
joba
投稿日時: 2015-10-6 14:00
開発者
登録日: 2006-4-27
居住地: Fukui
投稿: 597
Re: astah professionalでプラグインがインストールできません。
こんにちは。ご不便おかけしており申し訳ありません。
では、バージョン0.1.0のプラグインファイルでお試しいただけますでしょうか。

C++リバースプラグイン 0.1.0ダウンロード

ファイルをダウンロード後の手順は同じです。
動作報告、お待ちしております。
omae
投稿日時: 2015-10-13 23:37
新米
登録日: 2015-10-3
居住地:
投稿: 3
Re: astah professionalでプラグインがインストールできません。
ご報告遅くなりまして、申し訳ございません。
ご指定のプラグインバージョン「0.1.0」を適用したところ、
プラグインが有効となり、C++リバースも実行できました。
大変助かりました。ありがとうございました。
ちなみにバージョン6.5で使用できるプラグインの最新バージョンは、「0.1.0」となるのでしょうか?
webmaster
投稿日時: 2015-10-15 14:09
管理人
登録日: 2006-4-24
居住地:
投稿: 518
Re: astah professionalでプラグインがインストールできません。
こんにちは。
無事、C++ リバースプラグインがインストールできたとの事、安心しました。

> ちなみにバージョン6.5で使用できるプラグインの最新バージョンは、
> 「0.1.0」となるのでしょうか?

はい、その通りです。
C++リバースプラグインの場合、astah* professional 6.5でご利用できる最新の
バージョンは、「0.1.0」です。最新版のC++ リバースプラグイン 1.0.9が必要な
場合は、お手数ですが、astah* professional 6.7へバージョンアップをお願いいた
します。(ダウンロードはこちらから)

※ご注意
ご利用可能なastah*のバージョンは、ライセンスのサポート期間内にリリースされ
たものに限られます。そのため、astah* professional 6.7のリリース日である
「2013/03/14」以前にサポート期限が切れている場合は、お手数ですが、サポート
ライセンスをご購入し、サポート期間を延長してください。(サポートライセンス1ケ
で、サポート期間終了日より1年、延長できます。)
 
 ご参照FAQ:サポート期間の延長方法
       サポート期間が終了してから1年以上経過している場合

それではどうぞ、よろしくお願いいたします。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ

投稿するにはまず登録を